Re: [DML] Speedometer Erratic Swings
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [DML] Speedometer Erratic Swings





Sorry about misspells, it's late. Driving my brothers truck from Seattle to Maryland. I forgot to mention, when tightening the lower cable to the angle drive, cram grease in the bottom of the cable and tighten it down all the way. The cable housing should not move or rotate if properly tightened. 

Ian Yanagisawa

On Apr 14, 2014, at 11:54 PM, Ian Yanagisawa <texas.twister@xxxxxxxxxxxxx> wrote:

 

All the things suggested so far are good ones, but if have a couple of additions. A new dust cap is best and fairly cheap if this is the problem. Here are a couple of ways to find where your issue is that I have used.

Take the upper speedo cable off at the lambda counter and twirl it with your fingers, you should see the speedo move.  There will be a bit of resistance due to grease but it should spin smoothly.  If it feels stiff at one point in the rotation, it could have a kink from the routing of the cable and sitting so long. You can chuck the end of the cable in a drill and spin it at a steady rat and the speedo should maintain a steady reading. If I recall correctly 1,000 rpm  at the wheel is 60 mph, but the angle drive reduces this greatly, maybe 8 to 1 or so (I forget the exact number). At any rate just start with a slow steady speed and look for steady operation of the needle. Spinning it the wrong way won't hurt it you will just get no reading. Determine the direction w your fingers. If it jumps when you spin it then make the drill turn the same way. DO NOT USE THE DRILL TO FORCE IT TO TURN!

Jack up the car and remove the left front wheel, check the dust cap to see if the square hole has been rounded out.  If it has replace it or stick a little grease on the square end of the cable coming out of the axle (not much, wipe any excess off w your fingers) the get a hot glue gun and squirt glue in the square hole in the dust cap and jam it on to the end of the cable.  The grease will keep it from sticking to the cable but let it act a a male mold to tighten up the hole. Faster to do than write, lol.  

Unscrew the lower speedo cable from the angle drive and spin it with your fingers,  since the cable gets exposed to the elements due to rubbing of the cable housing letting water in, lack of lubrication, or not being tight at the angle drive, this cable is usually the one that fails, then the dust cap strips.  If it spins smoothly reattach the upper cable to the lambda counter and spin the lower cable with the drill.  Check for smooth operation.  If it does not, then you have some options. Replace the cable with a similar one, replace both cables with a long one that bypasses the lambda counter or get a Teflon lined lower cable.  I got one of these from Toby, it think, John Hervey has the long ones as well as stock replacements or stock from DMC.  The piece in the lambda counter is a steel tube with square ends both cables plug into.  I have never seen one break or strip out, but your testing should show if this id the culprit (hey I actually got to use culprit in a sentence!). 

The angle drive can also crap out on you.  Clean it and lube it without removing it first.  Spin the square end in the axle and check the rotation.  Stick a small screw driver in the output of the angle drive so you can feel if the gears are slipping.  Also check that the casing of the angle drive isn't separating where it is pressed together.  I had this happen on an after market one.  If it has then you may be able to tap it back together.  This can separate due to the cable only being kept on by the threaded end.  There is a bracket on the back of the dust cover and the cable should be securely fastened to it.  This prevent undue stress on the angle drive.  In my opinion the stock plastic piece is too insecure and does not grip the cable securely. This allows the cable to put stress on the angle drive when turning.  Many cars don't even have the and the cable just flops around.  I bolted a small bracket to the existing hole in the bracket and zip tied the cable to it.  Reattach your lower cable to the angle drive and do the drill test again.  Various replacement angle drives are out there.  I think it takes about a 1 3/8" wrench to loosen the axle nut.  It calls for something like 200 ft/lbs to torque it down, but there is no good way to do that unless you have a crows foot wrench you can put on your torque wrench and do the offset calculation. I just got it as tight as I could figuring I weigh 160 and I was hanging or standing on the wrench (hasn't come off yet)

I have never seen a bad head unit yet so I can't help you there, but this should at least identify it if it is the problem.  It is not hard to remove.

Some where in here you should have found and fixed your problem.  Test the components separately and you will find it and not tear anything up.  Sorry about the length of the post.

Ian Yanagisawa

On Apr 14, 2014, at 6:47 AM, MICHAEL W TOWNSLEY <michaeltownsley@xxxxxxxxxxxxx> wrote:

 

I took my 83 Delorean out for a spin yesterday after a long winter's hibernation.  I drove about 6 or 7 miles at speeds around 35 to 45 MPH and the car performed fine.  When I accelerated to merge on to a 4 lane highway the speedometer started swing back and forth wildly with 10 to 15 MPH variations. It seemed to be more stable in second gear however at low speeds it would drop to zero in 1st. In 3rd or 4th gear it swing back and forth wildly.  I thought I detected a slight periodic noise coming the left front tire area when accelerating after making a low speed turn.  Has anyone experienced this problem and been able to successfully correct it?  My Delorean has the Island Turbo setup with a 160 speedometer I am not sure if the after market speedo mod is the problem or not.  I have had the car for about 14 years and I have never encountered this particular issue before.



__._,_.___


To address comments privately to the moderating team, please address:
moderators@xxxxxxxxxxx

For more info on the list, tech articles, cars for sale see www.dmcnews.com

To search the archives or view files, log in at http://groups.yahoo.com/group/dmcnews





__,_._,___


Home Back to the Home of PROJECT VIXEN


Copyright 2006 ProjectVixen.com.  All rights reserved.

Opinions expressed in posts reflect the views of their respective authors.
DMCForum Mailing List Archive  DMCNews Mailing List Archive  DMC-UK Mailing List Archive