[DMCForum] Flat acceleration curve/Fuel system issues- Need advice
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[DMCForum] Flat acceleration curve/Fuel system issues- Need advice



I am at wits' end with my engine right now.

I'll describe the main symptom:

When accelerating, or under a heavy load like hill-climbing, the
engine bucks and the tach jumps a lot(seems to indicated a misfire or
non-firing of some cylinders). These days I only get about 1/2 to 1/3
pedal travel before the car does this.

If I don't push the pedal beyond the "failure point", the car
accelerates smoothly as fast as that much throttle will allow.

I have checked the lambda with a dwell meter. Frequency valve buzzes
away happily. I have tried cleaning the injectors with a special
pressure rig that Vixen Dave lent me (engine runs off of the can
contents). I have changed filters and tank pickupscreens several
times. Mike C. and I have inspected my tank. It's clean with no
floaties.

Coincidentally, my idle regulator (only 1 year old) hums as is should
but when you disconnect it with the car running, the idle doesn't
jump or change. Idle is rock steady at 800 rpm. Does that mean I have
a huge vacuum leak somewhere? I can't find one. My brass screws are
CLOSED and the throttle linkage setscrews are set completely shut. I
have a new O-ring on the idle regulator tube. I have the brass keeper
ring. When I pull the CO screw plug the engine stumbles mightily,
which Martin says should happen if all or most of the vacuum leaks
are plugged.

A fuel pressure test rig is in the mail, but I want to hear what you
all have to say.

Thanks,

Rich A.
#5335




Yahoo! Groups Links



Home Back to the Home of PROJECT VIXEN


Copyright 2006 ProjectVixen.com.  All rights reserved.

Opinions expressed in posts reflect the views of their respective authors.
DMCForum Mailing List Archive  DMCNews Mailing List Archive  DMC-UK Mailing List Archive