[DMCForum] No Power........STILL!!!
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[DMCForum] No Power........STILL!!!



Hi everyone. First thing I want to say is, I love this forum. It has
been very helpful.
Now on to my ongoing problem. When I rev the engine in my 83' it
wants to "Bog" down like its running out of fuel. If I hold the
throttle wide open, it will not rev much past 1500rpm. If I do this
to long, the exhaust pipe just after the converter gets red hot. This
leads me to think the engine is running lean per lack of fuel. The
car only has 19K, so I'm not thinking its a clogged converter. The
car starts and idles great. Heres a list of what I have done so far
and none of these items changed the problem.

-Fuel accumulator- replaced
-Fuel pump and new design P/U from Special T Auto- replaced
-Inside of fuel tank cleaned and wiped out
-Spark plugs and wires (8 mm)- replaced
-Distributor cap and rotor cleaned and reused
-Coil- replaced
-Timing checked-OK
-Unplugged o2 sensor and started engine- no change
-Fuel distributor removed with air plate- cleaned plunger that goes
through the center of fuel distributor
-Unplugged warm up regulator will engine was running- no change

It has been frustrating trying to find this problem. Any help with
this problem will be greatly appreciated.
Thanks
Ryan


Yahoo! Groups Sponsor
ADVERTISEMENT


Yahoo! Groups Links



Home Back to the Home of PROJECT VIXEN


Copyright 2006 ProjectVixen.com.  All rights reserved.

Opinions expressed in posts reflect the views of their respective authors.
DMCForum Mailing List Archive  DMCNews Mailing List Archive  DMC-UK Mailing List Archive